Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
Joined
·
430 Posts
Discussion Starter · #1 ·
Hey guys,

I purchased a Factory Pro shift kit and replaced the detent arm. All went fine and the instructions called for shifting through the gears to make sure it’s all good.

I managed to shift through all gears fine a couple of times but then I was only able to shift through 1st, neutral, and second. That’s it. Any ideas? :(


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
964 Posts
Unfortunately, I can't help on why it won't shift passed 2nd gear but I am interested to see if it helps with any false neutral shifts once you get it working.
 

·
Registered
Joined
·
218 Posts
Hey guys,

I purchased a Factory Pro shift kit and replaced the detent arm. All went fine and the instructions called for shifting through the gears to make sure it’s all good.

I managed to shift through all gears fine a couple of times but then I was only able to shift through 1st, neutral, and second. That’s it. Any ideas? :(


Sent from my iPhone using Tapatalk
Hey Mike, I installed one of these kits on my 848 a few years ago and I highly recommend it; I was getting a lot of false neutrals on the track and the shift kit eliminated them completely. This might sound simple, but did you install the spring in the right orientation around the detent arm and the 'rib' on the case?

I completed a how to video when I installed mine, and you can find it on my youtube channel at:




I hope this helps!


.
 

·
Registered
Joined
·
430 Posts
Discussion Starter · #5 ·
Hey Mike, I installed one of these kits on my 848 a few years ago and I highly recommend it; I was getting a lot of false neutrals on the track and the shift kit eliminated them completely. This might sound simple, but did you install the spring in the right orientation around the detent arm and the 'rib' on the case?

I completed a how to video when I installed mine, and you can find it on my youtube channel at:

https://youtu.be/c3QXwB9UROA



I hope this helps!


.
Hello xx848xx,

I actually followed your guide when doing the install myself which was VERY helpful! I did everything as you did to the letter, including torque specs. When I had it in there I followed the instructions and shifted through the gears and they all went in fine. I did this 2 times until the 3rd time I was not able to shift past 2nd gear. Very odd and worrying!

From my understanding, I will have to open the generator side cover and adjust the shift selector there which should solve my problem but I have no experience there.


I also, bought the Factory Pro lighter shift shaft return spring (https://www.bellissimoto.com/parts/...ighter-shift-shaft-return-spring-for-ducati-s) but haven't installed that yet and calls to remove the flywheel and shift selector so maybe I'll try that out too. I'll probably tackle that next week when I get the flywheel locking tool.

Any further advice is welcome! :/
 

·
Registered
Joined
·
7,654 Posts
I had that issue on a Triumph and it was the clutch not releasing . Are you spinning the rear wheel as you shift ? Sometimes there needs to be some rotation of the parts to help things slide and mesh.
 
  • Like
Reactions: fastfinch

·
Registered
Joined
·
3,670 Posts
Are you spinning the rear wheel as you shift ? Sometimes there needs to be some rotation of the parts to help things slide and mesh.
if you are doing this with the engine off and bike stationary, then this definitely. i usually rock the back wheel back and forward if i'm going through the gears. you need to have the dogs align tongue and groove style to allow the gears to slide into place.
 

·
Registered
Joined
·
964 Posts
Hey Mike, I installed one of these kits on my 848 a few years ago and I highly recommend it; I was getting a lot of false neutrals on the track and the shift kit eliminated them completely. This might sound simple, but did you install the spring in the right orientation around the detent arm and the 'rib' on the case?

I completed a how to video when I installed mine, and you can find it on my youtube channel at:

Great video xx848xx. I will use this whenever I get around to purchasing and installing the Factory Pro shift kit. I don't get too many false neutrals, but if I can eliminate just half of them, I'd be happy!

mf
 

·
Registered
Joined
·
430 Posts
Discussion Starter · #10 ·
Great video xx848xx. I will use this whenever I get around to purchasing and installing the Factory Pro shift kit. I don't get too many false neutrals, but if I can eliminate just half of them, I'd be happy!

mf
Guys,

It looks like its ok. You were right, It needed to have the wheel spin a bit while changing gears. Sorry for the noob mistake there! :nerd:

Anyways, I'm waiting for the flywheel tool to come in so I can replace the Shift Shaft Return Spring with Factory Pro 'Number 29' one.

As always much thanks and I'll let you know what my findings are once I get everything up and running again!

Cheers,

Mike
 
1 - 10 of 10 Posts
Top