Ducati.ms - The Ultimate Ducati Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello,

I have used my bike on and off this year.

One day the bike would not start, i pushed started it, used it and it did not recharge.

I trickle charged it, lights on, horn works loud, however, just clicks when i crank it.

I hooked it up to the car battery via jumper cables and the bike started just fine,

so im assuming its the battery.

Any thoughts?

Thanks
 

·
Registered
Joined
·
3,883 Posts
Sounds like the battery. But it could be marginal connections. If you do have a bad connection, you may be able to feel the wires/bolts/nuts for heat, after you press the starter button for maybe 10 seconds.

Make sure all battery-starting circuit associated hardware is CLEAN and TIGHT, and then try again.

Also, please put your bike (year/model etc.) in a signature file. Or tell us what we're dealing with...
 

·
Registered
Joined
·
7,031 Posts
They paint the frame before attaching the grounds. Try filing the frame clean and clean the ground cable ends. Also the starter motor hot contact tends to get corroded but be very careful trying to loosen it. Make sure the center post doesn't rotate when removing the nut or you will tear the wire off inside the starter. Spray it down with wd40 or such and hold the inner and outer nut and watch the post. If you get the nut to break loose, work it back and forth and be generous with the lube as you remove it or you'll be buying a starter.
 
1 - 3 of 3 Posts
Top