Ducati.ms - The Ultimate Ducati Forum banner

21 - 26 of 26 Posts

Premium Member
Joined
48 Posts
Discussion Starter #21
wow, the newbie straighten you right out iamzombie!
I'm for pc but i'm afraid to speak! 馃槅
:LOL::LOL::LOL:


I apparently broke some unwritten rule of the internet by offering a difference of opinion, apologies to everyone who was offended. (lol)
okay, maybe i was a bit harsh.... I am sorry, iamzombie. the dissing was just getting a tad repetitive and i snapped, lol. Please accept my apology, if we ever bump into each other i'll buy you a beer - how's that? :)
 

Registered
Joined
272 Posts
For what it's worth, Yaman connected to my setup remotely today and tweaked a few settings for my blipper and zeroed some 0 throttle low rpm settings because I complained of it smelling rich at startup, while it didn't solve all of my issues, it did make an improvement.
 

Registered
Joined
15 Posts
This must be the 2nd or 3rd time you've done this. Please stop jumping on every thread i have regarding rapid bike. I understand that it didn't work out for you (as you've stated multiple times), but it seems your experience is an outlier and TBH if you have a gripe with them, take it up with them. Start your own effing thread about your experience or whatever but please stop chiming in with the same tired, negative words on my threads.

I have had a great experience with Rapid Bike and I give them an A+. The EVO unit has transformed my bike in a great way. Sorry you didn't have the same experience.

Respectfully
Those of us on the fence appreciate different experiences to help inform our decisions.
 

Registered
Joined
15 Posts
I just installed my Leo Vince mid pipe cat delete on tuesday, and it hasn't stopped raining here since.(2010 multi1200S).I only have had one short ride in the rain since,and it seemed to run well, but not a big enough sample.I want to see how it runs before I spend the money on a rapidbike or alternative. Who has had success, and with which products?
 

Premium Member
Joined
48 Posts
Discussion Starter #25
For what it's worth, Yaman connected to my setup remotely today and tweaked a few settings for my blipper and zeroed some 0 throttle low rpm settings because I complained of it smelling rich at startup, while it didn't solve all of my issues, it did make an improvement.
that's awesome, thanks for responding. IIRC, your troubles began with the blipper? i can't remember that other thread....
 

Registered
Joined
272 Posts
Initially, I didn't find there was any benefit to adding the RB it smelled like it was running rich, it backfires a lot more than it did previously (Yaman explained this due a removed off-throttle fuel cut, said other fuel controllers would do it as well) and the QS/blipper didn't work well.

So far it's better since he tweaked some settings and zeroed some areas of my map, but overall I'd still say it was an expensive purchase for what it provided. Before I'd have given it a 4 out of 10, now it's maybe a 7?
 
21 - 26 of 26 Posts
Top