Ducati.ms - The Ultimate Ducati Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
297 Posts
Discussion Starter #1
I have a 95 900SS CR. It recently went in to my local shop for service. While there I had them do an oil change. Since then, twice, the oil warning light has flickered on and off a few times. I've never had that happen before in 4+ years of ownership. Once was at the very end of a ride. I stopped in the driveway to open the garage door and as the bike was in neutral the light flicked on and off 3 or so times. The other time was in the middle of a ride in heavy traffic. The orange light flicked on and off two or three times.

I know it's an air cooled bike and if you aren't moving you aren't cooling. I know they run hot in general, BUT, I'm not used to having this happen. What are some things that can cause this?

* oil pressure sending unit?

* modified exhaust flowing too much air? Can that cause problems?

* type of oil used in the bike? (Don't currently know what the shop used but have used Spectro Platinum4 Full Synthetic 15w50 in the past)

* some blockage in the oil cooler?

Anything else?

Thanks for your help.
 

·
Registered
Joined
·
577 Posts
That light you speak of is the oil pressure light. Check the connection next to oil fill plug. Hopefully it's just that and not the oil galley plug backing out :eek:

Also check the oil level, with the engine off and on level ground.
 

·
Registered
Joined
·
954 Posts
The oil pressure senders arent great in these, renewed mine last January - oil light wouldnt come on when the ignition was switched on?

Pop a new one in before you start panicking, they arent that expensive... :)
 

·
Registered
Joined
·
297 Posts
Discussion Starter #5
follow up

The lines and fittings should be good as they were replaced with fancy ones. I do tinker with idle speed since I have Keihin flatslides in 39mm. They have a dial that sticks off the side that allows you to adjust the idle speed. When the bike is cold started I have to speed the idle up during warm up to keep it going, then after riding a bit I have to adjust it back down. I do this all the time now so I'm constantly dicking with it. What should the idle speed be at as a minimum figure? Maybe I'm going to low. I've been going with 1100 or so.

 

·
Registered
Joined
·
954 Posts
Standard SS tickover is 1200, although the FCR's will allow lower? Got mine set at 1300 due to a light flywheel to stop it stalling at lights etc... :)
 
1 - 6 of 6 Posts
Top