Ducati.ms - The Ultimate Ducati Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Still having issues with my bike!!
Starts up and runs ok when cold, open road riding is good also..
But stopping at intersections, lights and general town idling around seems to make it run like a bucket of s...t!!
Popping and missing, then clearing out when back on the highway.

Suggestions?? Or do i take it to the shop and bite the bullet :think:
 

·
Registered
Joined
·
151 Posts
Does it have a temp guage? Might be losing compression when engine gets hot.
Mine goes from around 100C @ normal running straight up to 130-140C when queing in city traffic. One time it couldnt idle when that hot:mad:
 

·
Premium Member
Joined
·
1,198 Posts
99% of the time, when my SS is acting up, its the carbs'/fuel system.

I'd be looking at low speed jets myself. Gum, dirt, mis adjusted, whatever...

Bob
 

·
Registered
Joined
·
2,434 Posts
Sounds like junk in the idle jets. I'd remove the carbs and clean thouroughly. Could it be worn emulsion tubes in the carbs? Common issue with the Mikunis. Mine doesn't care how hot it gets; I didn't even keep the temp. gauge on my track bike. You do not need a temp gauge.
 

·
Registered
Joined
·
920 Posts
sounds like junk in the idle jets. I'd remove the carbs and clean thouroughly. Could it be worn emulsion tubes in the carbs? Common issue with the mikunis. Mine doesn't care how hot it gets; i didn't even keep the temp. Gauge on my track bike. You do not need a temp gauge.
+1
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
awesome guys, thanks for the info!!!! :D
I will have a play with the carbs again and i could well be back on with more queries!
 
1 - 7 of 7 Posts
Top