Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 14 of 14 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 · (Edited)
My 916 bogs down…. Feels like it was running out of fuel on one of my out of town trips….
But engine seem to run just fine….
I rested the bike and headed back home with out incident.. and home was about 70kms or about 43miles.

Thinking that dirt could have clogged up the fuel pump we took it apart and did found water and a few dirt particles…. Tested it and seems to ok….

Brought the bike out again for another out of town trip but just about 3kms from the house the bike died.. suddenly, starts again then dies… oh boy!!!!!

Felt like an electrical connection was lose somewhere…
Brought the tank down again and inspected every wire and connection we could think of or find…

Bike would then run great for a few minutes then cut out again….

What gives??

After talking with a few mechanics we decided to change the fuel pump since that was the only think we could think of right now….


Ill keep you guys updated….
 

·
Registered
Joined
·
1 Posts
Check the relays under the seat, if you're facing the rear of the bike, the right relay is the fuel pump relay. Swap the right relay with the left & see if it fixes the problem. I just replaced my fuel pump relay on my 1995 916 & it's running great again. You may also want to replace the fuel filter inside the fuel tank.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
Check the relays under the seat, if you're facing the rear of the bike, the right relay is the fuel pump relay. Swap the right relay with the left & see if it fixes the problem. I just replaced my fuel pump relay on my 1995 916 & it's running great again. You may also want to replace the fuel filter inside the fuel tank.
we did that... doesn't seem to be electrical..
everything seem to be in order..
fuel filter looks fine.. but will replace that too just to be sure..
 

·
Premium Member
Joined
·
8,765 Posts
Did you check the wires from the connectors just above the rectifier on the right side? If not, check them for evidence of burning or melting. Symptoms of your regulator/rectifier going out, common with the 916. However, you didn't mention your generator light going on and that usually accompanies this problem unless your generator light isn't currently working. Ducatis hate loose connections. Double check battery terminal leads and all electrical connections around it. If its not electrical then it sounds like fuel delivery. Seems to me your running all those issues down as we speak.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
Did you check the wires from the connectors just above the rectifier on the right side? If not, check them for evidence of burning or melting. Symptoms of your regulator/rectifier going out, common with the 916. However, you didn't mention your generator light going on and that usually accompanies this problem unless your generator light isn't currently working. Ducatis hate loose connections. Double check battery terminal leads and all electrical connections around it. If its not electrical then it sounds like fuel delivery. Seems to me your running all those issues down as we speak.
we did that to... also the rectifier connection were already modified..
battery has a good charge..

checked the charging system and everything seems to be ok...
 

·
Registered
Joined
·
237 Posts
we did that to... also the rectifier connection were already modified..
battery has a good charge..

checked the charging system and everything seems to be ok...
Its going to be a faulty engine speed sensor. Been happening more and more lately.
 

·
Registered
Joined
·
237 Posts
oh boy.. that sounds expensive....
got my fuel pump... will give feed back in a few days coz if it turns out ok i will have to do some extensive testing....
Less than the fuel pump most likely. I paid 50us on ebay a year or so back which fixed mine. Expect around 180 new. A chap in Queensland just paid around 170 for a new one. Fixed his problem. :)
 

·
Registered
Joined
·
149 Posts
IMO, I agree w/ russo916 that the relays are going bad. I had a similar symptons when mine started to go bad. The relays have a finite lifespan of 8'ish years or so. If yours have never been replaced, it's most likely they're starting to fail.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #10 ·
cured.. i think..

ok guys.. she has been running great now..
but only ride her around town and not much..

its been raining here...

but i few things ive noticed..
-the bike runs better now...
-it picks up the front wheel regularly now.. before it would just do it sometimes
-it runs smoother, before it runs rough sometimes must be running lean before
-the engine runs cooler now.. used to run hot.. almost overheat all the time
-the fuse under the seat for the fuel pump and engine management doesn't get hot anymore, it would melt the plastic of the fuse but not blow it.. again this must be the fuel pump being over worked


the fuel pump i bought is just your ordinary car fuel pump.. (for fuel injection)
the pump for ducati would cost me around 400-500usd here..
the alternative fuel pump was just over 50usd..

i also checked the regulator for the fuel but it seem ok.. ( we thought it could be dirty with gum since this bike was stored for about a year before i restored her..)

the fuel pump works just fine.. ill know more when i take her out of town..
i hope this post will help someone too..







also the strainer or filter that came with the fuel pump can be folded so it slides right in...

the fuel pump is also made by nippondenso...
we used to do this before when swaping car engines and we always use a standard fuel pump.. i figure if this work for cars why not for the ducati..

and to my knowledge.. fuel pressure is regulated by the regulator.. almost all efi engines i know works this way...

all i have to do know is test her at highway speed to see i it would provide enough fuel.. but i think it will..

hope this helps
 

·
Registered
Joined
·
724 Posts
Cool…. Do you have the P/N for the pump you used? Looks real close to the same.. Maybe even better -- ha!! That is a huge savings for the same requirement. I think you’ll be just fine as long as the pressure stays as required, and see no reason why it shouldn’t. :cool:

Good Job, and good luck…. keep us up to date and thanks for the post..:)
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #12 ·
Cool…. Do you have the P/N for the pump you used? Looks real close to the same.. Maybe even better -- ha!! That is a huge savings for the same requirement. I think you’ll be just fine as long as the pressure stays as required, and see no reason why it shouldn’t. :cool:

Good Job, and good luck…. keep us up to date and thanks for the post..:)
sorry.. did not get the part no. it was stamped in the side but i was looking for something else like the fuel pressure etc...
 

·
Registered
Joined
·
76 Posts
Hey Jodie...just wondering, Was the fuel line being primed when you were having problems? I'm just running down the lines of what's going on with my 749 and wondering if I need to change my pump as well cause i just replaced battery and the fuel relay pump but still messes up. MABUHAY!
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #14 ·
Hey Jodie...just wondering, Was the fuel line being primed when you were having problems? I'm just running down the lines of what's going on with my 749 and wondering if I need to change my pump as well cause i just replaced battery and the fuel relay pump but still messes up. MABUHAY!
if you meant that if i could hear the pump turn on or hear it pressurizing the fuel lines.. then yes...

the problem is that the fuel pump works... it was just a wild guess and since we could not think of anything else anymore..

like i said it died a slow death.. if it wasnt working in the first place then it would have been easy to diagnose, but it worked.. and there was no way for us to check if it was giving out the correct pressure.. :D
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top