Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter · #1 ·
Hi All

Been on the forum a long while , just never had any technical issue , I could n't sort out , but I seem to have a few technical difficulties though,
Got a 1992 851 with 7200mi in excellent nick .
2 months ago prior to purchase
Also the following work was done in June :
new battery , fuel filter,fuel pump,fuel injector, new spark plugs and new timing belts.

When cold , she just seems to run for 3-4 seconds and then die.
Hold hard open on the throttle then she revs high at 3000 and the runs for a while and dies.
When warm , (temp guage at just over 80 ?) and you roll on the throttle there is SERIOUS hesitation and lag and just irregular throttle control , from about 3000 on , 4000 on etc.
Any ideas?
the fuel system seems to have been sorted out.
I called the shop who did the work , and he said just run her on a long trip and that'll work the kinks out .

So any words of advice and wisdom would be appreciated.

regards
mtnman
 

·
Registered
Joined
·
150 Posts
Hello, nice to see an 851 on the board. Have tried to adjust your mixture? I had the same problem with my 888 and found it was running rich. After adjusting it to the midpoint 2.5 volts I ended up at 0.65 volts and about an 1100-1200 idle. Hope this helps
 

·
Registered
Joined
·
210 Posts
Discussion Starter · #3 ·
Problem solved , turns out the other dealersip replaced the fuel filter , but never bothered to replace the 20 yr old fuel piping :think:

Anyhow , my dealer , Moto Forza sorted it out in less than an hour and were awesome, excellent service.
 
1 - 3 of 3 Posts
Top