Ducati.ms - The Ultimate Ducati Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
469 Posts
Discussion Starter #1 (Edited)
Everything physically matches up, however can I simply install my 848SF tank on the SFS without swapping pumps and quick disconnects/sensor?

I installed the RapidBike Evo and the dash is displaying the oil pressure lamp and the engine cranks, but will not turn over. No codes or other error lamps are displayed. Trying to troubleshoot this.
 

·
Registered
Joined
·
3,371 Posts
You should be able to swap tanks without any problems. As far as I know the fuel pump assembly is the same on both bikes. You may want to cross check part numbers on that to be sure. Make sure you hear the fuel pump priming when you turn the key on.

The oil pressure light should be on when you turn the key on. As the engine cranks over and fires it should go out. Just as the engine starts oil pressure builds to normal levels and the light goes out.
 

·
Registered
Joined
·
140 Posts
Guy here in DFW did the same thing and everything was a match for his 2011 SFS.
Shouldn't be an issue.

--Randy
 

·
Registered
Joined
·
469 Posts
Discussion Starter #4
Thank you fellas. Now that that's out-of-the-way, I need to investigate further… Pinched lines, bad connection, etc. I will report back.

I'm guessing the oil pressure indicator is remaining on simply because the engine is just cranking and not starting up, not necessarily due to an oil related issue.
 

·
Registered
Joined
·
469 Posts
Discussion Starter #6
All sorted everything was correct. Just needed to install the reverse polarity cable as part of the RapidBike Evo kit.
 
1 - 6 of 6 Posts
Top