Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Well finally decided, I better do a check over, some missing as well with the Tacho jumping around, so assumed ECU or CPS. Have been riding for 12 months and bit worried about what I will find....

Kms - 19500

Checked Belts - all seem OK will change next year

Ordered a new CPS from eBay USD 22 delivered to NZ the Fiat Punto one.. fitted up just fine, had to add some shims to get 0.65mm, but seems to have fixed the misfire - so pleased doesn't appear to be ECU related.

When I started to look the header tank had been split, looks like over tightening the filler mounts, the filler has an o-ring seal. The mounts for the pressure sensor where super tight and corroded. The leak was around the threaded inserts holding the filler in place. Ordered a new replacement one from Ducati dealer in Hamilton ~NZD100 delivered, which I thought was pretty good.

Replace the throttle cable while the chamber is still loose and put the rubber seal to access the throttle back in as well, then out the whole thing back in to the frame - there is not much room to do it afterwards

Replaced the glycol, cleaned out the intake to water pump some corrosion, so removed that, chipped off the rust and neutralised the rust.

Did valve clearances - mostly OK, adjusted 1 closer. not a big deal, marked the belts, took photos setup for TDC on the horizontal cylinder and left it there. The closer clearance was by luck, on this cylinder. Did loaded / unloaded.. didn't have long / bent enough feeler gauges to reach the back to the closer cam.

Getting belts on is only a hassle on the vertical cylinder so made a wooden handle so I could adjust / hold in place, while tightening things up.

Cleaned air filters - all just oil soaked foam - so washed and returned into place. The PO had broken the plastic lugs that the the self tappers screw into holding the intake halves together - I assume over tightening have put a few back in the interim and ordered some brass inserts so will put these in when I receive with some M3 Hex cap screws and washers. Make sure the clips are in prior to fitting as they will interfere with the frame and you will have to remove again to fix

Replaced the battery with a Gel one, will have to add a strap or the like as the fin on the top of the battery is non existent on the replacement.
Cranks a lot better..battery was over 6 years old by the Yuasa guys

It actually started straight away - huge relief! Miss seems better, still doesnt like low revs, but believe this is pretty standard.

Sorry for the short novel...
 
  • Like
Reactions: Jyrki and xracer

·
Registered
Joined
·
46 Posts
Discussion Starter · #5 ·
Thanks Crew,

Starts / Runs / Idles real good.. only issue is slight backfire on coming off the throttle? Any thoughts?
 
1 - 7 of 7 Posts
Top