Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 18 of 18 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
I got the Rexxer remap a few months back and like many others who have posted in the past, there is a very noticeable flat spot in the torque curve around 4500-6000 rpm.

I’m wondering if this may be caused by the O2 sensors trying to adjust the air/fuel ratio? The flapper valve is disconnected but I don’t know if the reflash was written to also override the O2 sensors.

Do you think if I disconnect them that would fix my problem? If so, do you know where I can get plugs so that the CEL doesn’t come on? If you do not think it will help me, please elaborate.

Thanks!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
60 Posts
no, it will not fix the problem.
rexxer has many files with a flat spot / delayed throttle response in this area.
i complained 2 or 3 files until i received a file from them (rexxer germany, from sebastian) which works great without delay in the area between 4000-5000 when opening throttle.
my map is named "VS_T1_smooth" and is based on my 939 Hyperstrada map ( HS939_tuning_ferdi_120917.usr ).

VS_T1_smooth is a file where the exhaust flap is not deactivated because i deactivate the flap by myself with healtech exhausteliminator. This has the reason that police is very restrictive in my area and they make also technical checks of the bikes. so my bike is complete stock (except the map nobody can check) when i have eliminator disconnected.
Basically VS = valve stock , VN = valve no = deactivated
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #3 ·
no, it will not fix the problem.
rexxer has many files with a flat spot / delayed throttle response in this area.
i complained 2 or 3 files until i received a file from them (rexxer germany, from sebastian) which works great without delay in the area between 4000-5000 when opening throttle.
my map is named "VS_T1_smooth" and is based on my 939 Hyperstrada map ( HS939_tuning_ferdi_120917.usr ).

VS_T1_smooth is a file where the exhaust flap is not deactivated because i deactivate the flap by myself with healtech exhausteliminator. This has the reason that police is very restrictive in my area and they make also technical checks of the bikes. so my bike is complete stock (except the map nobody can check) when i have eliminator disconnected.
Basically VS = valve stock , VN = valve no = deactivated


Thanks, I will talk to my dealer and see what they say


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
60 Posts
i think my above post is still right even i misread lambda eliminator with exhaust eliminiator.
i have no idea if a lambda eliminator will work with the euro4 engines also. euro3, like the 821 ones, are much easier to fool.
if you will try a lambda eliminator, i first would try it with the stock map, without rexxer.
in september 2017 rexxer had no real working file with deactivated o2 sensors, so i use a rexxer with o2 still active.
with my former 821 the rexxer with deactivated lambda was excellent, unfortunatly this seems not to be so easy with the 939 engines.
maybe they already found out how to fool the euro4 sw of the iaw7 ecu.
but if someone does know this, then sebastion from rexxer/daniele moto in germany (they are the inventors of rexxer) - https://www.daniele-moto.de/en/index.html
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #5 ·
i think my above post is still right even i misread lambda eliminator with exhaust eliminiator.
i have no idea if a lambda eliminator will work with the euro4 engines also. euro3, like the 821 ones, are much easier to fool.
if you will try a lambda eliminator, i first would try it with the stock map, without rexxer.
in september 2017 rexxer had no real working file with deactivated o2 sensors, so i use a rexxer with o2 still active.
with my former 821 the rexxer with deactivated lambda was excellent, unfortunatly this seems not to be so easy with the 939 engines.
maybe they already found out how to fool the euro4 sw of the iaw7 ecu.
but if someone does know this, then sebastion from rexxer/daniele moto in germany (they are the inventors of rexxer) - https://www.daniele-moto.de/en/index.html


Yeah I’m gonna try disconnecting my O2 sensors and see if that does anything.

Alternatively, do you think a piggyback unit like rapid bike or Bazzazz would remedy the issue, if it is indeed an issue with the air/fuel ratio?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #9 ·
No, just the rapidbike. It bypasses the stock O2's and lets you tune the whole RPM range.


Oh ok. I’m hoping my dealer can figure out what exactly is wrong, or switch my bike back to the factory tune, refund my money for the Rexxer, so I can take that and buy a rapidbike unit.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
99 Posts
I have the same concerns with my Rexxer map. I had my dealer flash it when I installed my pipe. I was really bummed when I got it back and the o2 sensors were still hooked up...

I'd love to find a canned solution and not mess with it, rather than going with the Rapid Bike option. My bike is also geared down a tooth on the front sprocket so at highways speeds I'm right in the dead spot. The bike just falls on its face when I roll the throttle on hard. :(

Has anyone had any luck moving this forward?
 

·
Registered
Joined
·
60 Posts
I have the same concerns with my Rexxer map. I had my dealer flash it when I installed my pipe. I was really bummed when I got it back and the o2 sensors were still hooked up...

I'd love to find a canned solution and not mess with it, rather than going with the Rapid Bike option. My bike is also geared down a tooth on the front sprocket so at highways speeds I'm right in the dead spot. The bike just falls on its face when I roll the throttle on hard. :(

Has anyone had any luck moving this forward?
problem with rexxer dealers mostly is that they do not make own maps by themself but take fixed maps from rexxer and lay it above your map.
rexxer germany, especially in person of sebastian, makes also changes when you tell him your problem.
he needed 3 files, but the third one resolved the bogging and mine has no flat spot any more.
 

·
Premium Member
Joined
·
13 Posts
I have a new person question. Are these solutions an alternative to the full Termignoni exhaust and map? Or does the full Termignoni system not address it either? I just got my first Ducati and was really surprised at how poorly thhe fueling was compared to my Japanese bikes. I really like the bike but am stuggling wig being smooth with the throttle and am very intersted in a solution. Thanks
 

·
Registered
Joined
·
60 Posts
I have a new person question. Are these solutions an alternative to the full Termignoni exhaust and map? Or does the full Termignoni system not address it either? I just got my first Ducati and was really surprised at how poorly thhe fueling was compared to my Japanese bikes. I really like the bike but am stuggling wig being smooth with the throttle and am very intersted in a solution. Thanks
if full Termignoni means "no cat" and "no lambda" there imho is no real alternative.

unfortunatly this is not possible where i live because of yearly inspections and police controls. But, if this is not the case where you live and you can drive unchallenged over years, go the full termi trail
 

·
Premium Member
Joined
·
13 Posts
Thanks for the response. I guess Im fortunate i have low restrictions. I hope you get your fueling sorted out.
 

·
Registered
Joined
·
60 Posts
took this thread as occasion to contact Rexxer Germany / Sebastian again per mail yesterday.
He answered immediatly and sent me 2 new files where lambda is disabled for my 939. Checked it in the evening by pulling O2 sensor and yellow light did not come, which comes immediatly with a mapping with lambda active.
I also could smell at idle that lambda seems not to be 1 :).
Did not manage to testdrive it longer, only a little round around the village, but first impression is very positive, 939 seems to be transformed.
second gear, 4000 U/Min - no bugging, no surging, just smooth throttle response and driving.
Will keep you updated after the weekend, but Rexxer seems to have a breakthru with lambda disactivating at the Euro4 models of Hypers.
 

·
Registered
Joined
·
99 Posts
Any luck over the weekend? I was thinking of heading to my dealer to ask them about it. Unfortunately I don't have the Rexxer Unit, so I will have to have them do the re-flash...I really should have thought that through.
 

·
Registered
Joined
·
60 Posts
Any luck over the weekend? I was thinking of heading to my dealer to ask them about it. Unfortunately I don't have the Rexxer Unit, so I will have to have them do the re-flash...I really should have thought that through.
yes, did some testdrives.
it runs fine, but the difference is not as big as i thought at my first round. seems cold engine fooled me a little because it runs richer durring warmup.
but, it runs really smooth thru the rpms, also low rpm with very low load. it definitly runs better than with the lambda active file, but the differnece is not really big.
at my 821 the difference was much bigger, but she also did not run as smooth as my 939 wit hlambda active.
if you are not satisfied with your mapping at time, it's definitly it's worth a try.
my file is named VS_LN_T3_MOD1 , you would need a VN_LN_T3_MOD1 because i suppose you want exhaust valve also disabled.
I disbale valve with healtech exhaust eliminator.
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #18 ·
yes, did some testdrives.

it runs fine, but the difference is not as big as i thought at my first round. seems cold engine fooled me a little because it runs richer durring warmup.

but, it runs really smooth thru the rpms, also low rpm with very low load. it definitly runs better than with the lambda active file, but the differnece is not really big.

at my 821 the difference was much bigger, but she also did not run as smooth as my 939 wit hlambda active.

if you are not satisfied with your mapping at time, it's definitly it's worth a try.

my file is named VS_LN_T3_MOD1 , you would need a VN_LN_T3_MOD1 because i suppose you want exhaust valve also disabled.

I disbale valve with healtech exhaust eliminator.


So the VS file does not disable the flapper, but the VN file does? But both override the lambda?


Sent from my iPhone using Tapatalk
 
1 - 18 of 18 Posts
Top