Ducati.ms - The Ultimate Ducati Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hello, I have a 2010 Hypermotard 1100cc. I installed a termignoni exhaust and I have changed the ECU. One day before a month, I received a fault "error TPS 1.1".
At garage the mechanic told me that ECU was permanently damaged and he changed it with new one.
After a couple days I received the exact same fault "error TPS 1.1" again. The mechanic told me that a wire of bike's electrics didn't have ground. He "fix" it.
After a few days one cylinder stop working. But if you switch off the bike for about one or two hours, the cylinder working good for couple days. After a few days I had again the problem with cylinder and I use the "solution" that I mentioned before.
The mechanic told me that the solution for cylinder problem was to change the ignition coil for this cylinder. After a few days with new ignition coil, I had the problem with cylinder AGAIN.
Please, help me what to do because we can't find the REAL solution.

Thanks in advance

P.S. When my bike is on with only one cylinder working, my bike didn't turn off with the key.
 

·
Registered
Joined
·
274 Posts
How does it run if you reinstall the stock ECU?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
@GRR_Hyper
I didn't try to reinstall the stock.
But if I reinstall it, I can't figure if I find the solution because it could take several days to show it
 

·
Registered
Joined
·
324 Posts
I would like to know what he charged you for the ECU, parts and labor. Being a Ducati dealer doesn't mean they are doing repairs correctly.

Please complete your profile so we know where you are located.
 
1 - 8 of 8 Posts
Top