Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I was ready for a ride this morning and after the usual cycling of dash lights, I was left looking at the red oil pressure light and no ignition. The bike went perfectly a few days ago, all lights and dash appears normal. Kill switch off, oil level normal. Turning ignition on and off gave the same result. Any ideas about what I should start looking for would be appreciated.
 

·
Registered
Joined
·
20 Posts
Oil pressure light stays on when ignition is off, as there is no oil pressure.

Does the immo light blink?
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #4 ·
With the ignition on I hear the fuel pump working and immobiliser light disappears. Lights, indicators and dash appear fully functional. The red oil pressure light stays on. No response at all when pressing starter button and engine does not start. Reconnected to my battery tender and nothing changed?
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
Problem solved! I noticed that the neutral light was not on although the bike was technically in neutral and the rear wheel spun easily, so I engaged 1st and put it back into neutral. Hey presto , neutral light and the bike starts. Big relief. Thanks to those who replied so promptly. I thought I would be up for a lengthy troubleshooting.
 
1 - 5 of 5 Posts
Top