Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Good Afternoon all,

I recently picked up a 749S that I am trying to get into shape. The dash reports codes for right fan shorted to ground and Immobilizer serial cable disconnected. The bike starts right up and runs fine (with the left fan going constantly).

FOR THE FAN:

So far I have connected 12V directly to the right fan and it spins right up. I can also connected the middle pin on the diag cable to the battery ground, though, now that I think about it the paperclip I inserted in the connector probably wasn't enough to carry a proper ground.

I have also tried to measure continuity between the ECU and the FAN by disconnecting the ECU but could figure what pin on the ecu cable i should be using (BODY 14) per the diagram any idea how I can do that without cutting into the insulation?

FOR THE IMMOBILIZER:

I have reseated the cable steering stalk - no joy. If it had been disabled though Ducati diag or jpdiag would it throw a CEL? Would it still display code of the dash during the startup sequence?
 

·
Premium Member
Joined
·
2,072 Posts
You might want to try replacing the relays. I had the same situation with my ST4s - fan on all the time, as well as the headlight - and it was the relay. Just a thought.

Ron
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #4 ·
So I chased the ground side of the right fan back to the ECU and checked for continuity. Once I was satisfied that wasnt the problem I use a wire to jump the positive of both fans together since the issue seems to be on that side. With the jumper wire the CEL is OFF I guess it stores code for a while after they occur.
 
1 - 4 of 4 Posts
Top