Ducati.ms - The Ultimate Ducati Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hey guys,

Friend picked up a 2002 Monster 620D with 8000 miles. Seemed to be fine when we picked it up but after about a day or two of riding it, friend stalled the bike and tried to start the bike again but wouldn't go. Seemed like a dead battery problem so got a jump kit to restart it and the bike was able to start but then was not able to hold a high rpm (even with choke on high) and would turn off and not be able to start again.

Went to get a new battery and installed that in the bike. Bike seemed to be working fine and friend rode for another day but after getting lunch bike died again and is doing the same thing with the new battery.

Did some research and saw that the problem may be with alternator or rectifier? Not too handy with bikes yet so please excuse me if I'm way off.

Just wanted to see if anyone had this problem of the battery being drained and when jumped it is not able to hold a RPM above 1000 causing the bike to turn off.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #2
Also the battery we got from auto zone was supposed to be a temp thing. It wasn't the exact fit for the bike but guy said it should work till we get a better battery but didn't think a problem should arise again so fast. Seems like the problem is not the battery wanted to add in that the new one we got isn't the exact fit.
 

·
Registered
Joined
·
18 Posts
The electrical system could have a short in it as well. I used to have a 620... Similar issue...it was almost like on cylinder was not firing at all. The battery kept dying too.
 
1 - 8 of 8 Posts
Top