Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
I haven't ridden my 1098s in almost 2 months, and I took it out this past sunday. Everything was fine, except the brake seemed spongy and not as tight as i thought it used to be. I also noticed that both resoviors looked full to the max. I bled the brakes today, and really didn't notice any air at all. so I removed the caps, and the seal on the brake was pulled all the way down, so I fixed that, and then the clutch was so full, that after I removed the cap, it leaked out a bit. Not sure what is going on. Any ideas or help would be appreciated.
 

·
Registered
Joined
·
699 Posts
Try bleeding. I had an issue with my master on my 07 1098S, was replaced under warranty. But try bleeding, has been a good fix on all my bikes with spongy front brakes, especially after hard use. Fran Hope this helps!
 

·
Registered
Joined
·
1,379 Posts
It either needs bled or your master is bad. Bleed it front the top, bottom, tap on it, curse at it, threaten to install it on a GSXR. If none of those help then it is time for an upgrade.

t_bare
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #5 ·
It either needs bled or your master is bad. Bleed it front the top, bottom, tap on it, curse at it, threaten to install it on a GSXR. If none of those help then it is time for an upgrade.

t_bare
I didn't try bleeding from the top
 

·
Registered
Joined
·
1,494 Posts
I didn't try bleeding from the top
What happens when you at a zip-ty over the night? When it feels firm at first and after a short ride become spongy again, your master is bad. I had this with a Brembo radial master on my Aprilia.
 

·
Registered
Joined
·
230 Posts
Have you changed your levers or are they stock? If you changed them, I would quess that the levers are putting pressure on the master pistons, which are blocking the bled holes in the master and fluid isn't flowing correctly. Just a guess....
 
1 - 8 of 8 Posts
Top