Ducati.ms - The Ultimate Ducati Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
1 - 12 of 12 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 · (Edited)
Hi folks,

I replace the regulator and reconnect stator wires to R/R and wires between R/R and battery. I got connection issue after I get done these, because I forgot to get ECU ground. This is the thread about this issue posted here. https://www.ducati.ms/forums/56-superbikes/719115-1098-regulator-replacement-error-can-38-0-a.html

Now, The bike can start but act weird. Bike starts at low rpm 1300-1400 (1500 is normal), and exhaust chokes, and bike will stall. I can smell gas from exhaust and I can tell the engine sound droning, compared to before R/R replacement. It sounds like gas isn't mixed well with air? I doubt if I change something for ECU, if possible? (I don't know about electrics)

It's 07 ducati 1098 with 70mm full carbon termi exhaust.

 

·
Premium Member
Joined
·
5,151 Posts
To check which one let the bike run to 30 seconds and spray each exhaust pipe at the cylinder head. The one that’s working will steam straight away and the other will drip. Then determine if it’s spark or fuel that’s causing the problem.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #4 · (Edited)
To check which one let the bike run to 30 seconds and spray each exhaust pipe at the cylinder head. The one that’s working will steam straight away and the other will drip. Then determine if it’s spark or fuel that’s causing the problem.
I haven't ride my bike for 2 months, due to the electric issue. Maybe it sits in garage for too much time?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #5 ·
To check which one let the bike run to 30 seconds and spray each exhaust pipe at the cylinder head. The one that’s working will steam straight away and the other will drip. Then determine if it’s spark or fuel that’s causing the problem.
It's the pipe circled in picture that doesn't work.

But, the engines run normally after the bike starts about 1.5 mins.
 

Attachments

·
Premium Member
Joined
·
5,151 Posts
You can’t tell at the muffler as the pipes merge into one pipe and then rejoin under the seat. YOU NEED TO FOLLOW INSTRUCTIONS SOMETIMES. Read again my first reply to you.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #7 ·
You can’t tell at the muffler as the pipes merge into one pipe and then rejoin under the seat. YOU NEED TO FOLLOW INSTRUCTIONS SOMETIMES. Read again my first reply to you.
It starts good now. Lol

I will test it tomorrow to see if this issue comes back.
 

·
Registered
Joined
·
496 Posts
Hi folks,

I replace the regulator and reconnect stator wires to R/R and wires between R/R and battery. I got connection issue after I get done these, because I forgot to get ECU ground. This is the thread about this issue posted here. https://www.ducati.ms/forums/56-superbikes/719115-1098-regulator-replacement-error-can-38-0-a.html

Now, The bike can start but act weird. Bike starts at low rpm 1300-1400 (1500 is normal), and exhaust chokes, and bike will stall. I can smell gas from exhaust and I can tell the engine sound droning, compared to before R/R replacement. It sounds like gas isn't mixed well with air? I doubt if I change something for ECU, if possible? (I don't know about electrics)

It's 07 ducati 1098 with 70mm full carbon termi exhaust.

https://www.youtube.com/watch?v=XxhXzRlIypY
What language is this?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #12 ·
You can’t tell at the muffler as the pipes merge into one pipe and then rejoin under the seat. YOU NEED TO FOLLOW INSTRUCTIONS SOMETIMES. Read again my first reply to you.
Now the bike can start and run normally. I hope the one cylinder running issue is temporary.

Maybe it sits in garage for long time.


Anyway, thank you for the help! I appreciate it!
 
1 - 12 of 12 Posts
Top