Ducati.ms - The Ultimate Ducati Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all ... I just bought a 2004 Multistrada 1000ds ... When it is running when opening throttle in any gear it will act fine for a second then its like a quick loss of power kind of like its bogging down then it will go back to normal its like it has hickups .... It is the worst when accelerating hard.......also dies out sometimes when brought back to an idol .........any suggestions on what a fix might be???
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Im pulling tank this weekend ...ive changed all 4 spark plugs....and am running seafoam pretty heavy in gas tank to try and help clean possibly bad/old gas.....ill check the air filter .....is the fuel filter inside the tank?
 

·
Registered
Joined
·
80 Posts
Fuel pump relays are common to go out on air-cooled Multistradas. I carry a spare, you can try swapping out the headlight relay to see if it makes a difference.
 

·
Premium Member
Joined
·
4,691 Posts
Im pulling tank this weekend ...ive changed all 4 spark plugs....and am running seafoam pretty heavy in gas tank to try and help clean possibly bad/old gas.....ill check the air filter .....is the fuel filter inside the tank?

Too much seafoam= bad gas

drain and fill with fresh gas before you go crazy. If you pull the tank reinstall within hours, it will swell overnight and not go back in
 

·
Premium Member
Joined
·
4,691 Posts
Fuel pump relays are common to go out on air-cooled Multistradas. I carry a spare, you can try swapping out the headlight relay to see if it makes a difference.
really is either ON or OFF, when it craps out you are dead in the water. Don't waste your time, as useful as checking tire pressure in this case
 

·
Registered
Joined
·
95 Posts
There is an issue with the wires that go into the fuel pump, the wires work loose and you have intermittent pressure. You can take the pump out and dig out all the epoxy around the wires. Then solder the wires back in. Or buy a new pump $$$$
 

·
Premium Member
Joined
·
4,691 Posts
There is an issue with the wires that go into the fuel pump, the wires work loose and you have intermittent pressure. You can take the pump out and dig out all the epoxy around the wires. Then solder the wires back in. Or buy a new pump $$$$
None of the symptoms he described seem to do with intermittent electrical issues, bogging on acceleration, dying when comes back to idle, both point fuel mixture/bad fuel/throttle body/TPS/ possibly even bad ignition coil/wire. But I would start with fresh fuel, tank full of Stabil is never a good thing
 
1 - 10 of 10 Posts
Top