Ducati.ms - The Ultimate Ducati Forum - Reply to Topic
Thread: Multistrada lacks power Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ducati.ms - The Ultimate Ducati Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
May 21st, 2019 8:44 am
Chuckracer Hi Rob and welcome to Ducati.ms. If you could take a sec and fill out your location information in the "UserCP" section and add your bike to the Signature line, we'd appreciate it.

I will copy this post to the Multistrada section where you will surely get some good answers. Good luck with it! It's gotta be something simple.
May 21st, 2019 8:20 am
Rob Neal
Multistrada lacks power

I have a 2017 Multistrasda. She's been in the garage for a while and I think that this may be part of the problem. When accelerating it does not reach the power band. It gets to about 4000rpm and then stops pulling. I think that this maybe down to a stuck valve in the exhaust system but would appreciate any more advice. Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome