Ducati.ms - The Ultimate Ducati Forum - Reply to Topic
Thread: Catastrophe on day 1 post rebuild. Airbox lid lifted, motor ate sand. 900SS CR Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ducati.ms - The Ultimate Ducati Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Apr 12th, 2018 12:59 pm
spacey "PI" is likely Pro-Italia. They are a European motorcycle dealer in the Los Angeles area. Back in the day the prior owner also made a few low volume parts. I had a PI slave on my '92 which was designed to reduce lever force with the trade-off that linear motion of the slave was also reduced. Mine worked fine with the stock clutch pack until the seals failed. I rebuilt it once and next time it failed I got a Yoyodyne.
Apr 12th, 2018 12:14 am
Lelebebbel So thanks to a local rider I got my hands on some extra 1.5mm driven plates. I added two to the stack for about 38mm total height. This resulted in a fair bit of clutch drag (rear wheel spins when on a stand in first with clutch pulled, neutral near impossible to engage, big clunk when shifting into first).
I bled the clutch to be sure that wasn't the problem, it made no difference. The clutch lever actually hits what feels like a hard stop about 1/4" before touching the bar, so something is bottoming out before the clutch is fully disengaged with the 38mm stack.

However a quick road check verified no more slip.

I then removed one of the extra discs for a total stack of 36.5ish mm. This solves the clutch drag issue, everything is back to normal. It got too late to check for slip though.

I have an aftermarket slave on there, not sure what brand. The engraving looks like "PI" or "IP"?

What could be the issue here? Is the slave bottoming out, and if so, why is the clutch not fully disengaged at that point? Is my clutch rod too short somehow?

Edit: ... Or maybe too much axial play in the drive shaft?
Apr 7th, 2018 7:01 pm
bradblack that looks like the newfren ones. i put a set in a customer's sf1098 on friday, will see how they go.

the aluminium tangs are much narrower than the oem ones, about the same thickness as a steel plate tang. so i'm interested to see how they pound out. i fitted them into a light steel basket, which may exaggerate it.

the 1098 packs have 8 frictions and mostly 1.5mm steels, with a couple of 2mm steels at the back. they're usually about 41.5mm thick, and the oldies are 38.5mm.
Apr 6th, 2018 10:41 pm
ducvet Definitely not Barnett they do look to be new from the tab wear. I cannot tell if they are oem from the picture but they look good to go. I would swap some of the 1.5's for 2mm's and run it.
Apr 6th, 2018 6:28 pm
Lelebebbel Yes I am unsure how all these 1.5mm plates got in there, and where they came from. It must have been recycled parts, because the doubled up steel plates at the bottom of the stack have the faint outlines of the friction pads on them, as if they were resting against a friction plate at some point and picked up some rust. Which is impossible given the order/orientation they were stacked.

But they are definitely all 1.5mm. There is no ridge between the friction surfaces and the teeth so there is no way they were ever any thicker. I checked all plates and none of them have any punch marks, all are perfectly flat when placed on a piece of glass.

The steel plates I just bought are from some sort of a 2005 Monster. A full set. When asked, the seller said they are 1.5mm, although they may have just measured one of the thin ones by chance.
Apr 6th, 2018 5:02 pm
ducvet Probably not the fact the plates are worn as much as the 1.5mm plates should be 2.0mm plates. In a oem pack you only have the two 1.5mm and one is cupped. Be sure to look for a punch mark to find the cupped plate it is subtle. It sounds more like a Barnett or other aftermarket. any chance we could get a picture?

Either way as others have said fattening up the pack will probably fix you up, see if anyone near you has a old oem pack and swap a couple 1.5's for 2.0's.
Apr 6th, 2018 4:04 pm
Lelebebbel Ah, didn't think of that!
I just found a used complete set of steel plates from a 2005 Monster on ebay that should hopefully have the cupped plate in there. Also getting a single OEM friction plate. So that should give me a few options to make this clutch work properly.

Marocco4speed is a pretty handy shop as well, that's where I got the gasket set for my motor.
Apr 5th, 2018 7:30 pm
bradblack there's a place in germany that sells plates on ebay. morroccoforspeed or something like that.

if you get a decent load on the springs i think you'll need a cupped plate for progression.
Apr 5th, 2018 1:00 pm
Lelebebbel Thanks. It's all OEM Ducati stuff from what I can tell, but given all the other stuff I found on this bike, I suspect it could be a collection of parts from different bikes. All the steel plates are 1.5mm, but none are cupped. The friction discs are steel and look like OEM to me. Clutch basket and hub are OEM, no slipper or anything. The hydraulic slave is an aftermarket CNC unit, maybe Oberon.

The clutch bites very late (lever most of the way out). It doesn't screech and I wouldn't call it grabby, but it slips in 4-6th gear at full throttle.


Ducati will neither sell me individual friction discs, nor a pack of steel plates. Off to ebay again, I guess.
Apr 5th, 2018 7:54 am
ducvet Is it a slipper clutch or Barnett?
Oem should have 2 1.5mm plates and one is a cupped spring plate.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome