Ducati.ms - The Ultimate Ducati Forum - Reply to Topic
Thread: Aussies Only please Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ducati.ms - The Ultimate Ducati Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Aug 28th, 2017 5:14 am
cb4265
Quote:
Originally Posted by cb4265 View Post
I nearly spent $380 on a battery? I think I am loosing the plot.

Craig
It turns out the charger was fucked and has been replaced with a new one under warranty, so I am dammed impressed with CTEKs warranty and customer service. I did 800 plus kms over the weekend without assistance traveling to Morgan Park for the Super Bikes, which I thoroughly recommend for next year.

Great weekend, and thank you to DTM Tamworth & CTEK

Craig
Aug 14th, 2017 6:32 am
cb4265
Quote:
Originally Posted by Satansfist View Post
Bitch...
I nearly spent $380 on a battery? I think I am loosing the plot.

Craig
Aug 14th, 2017 6:20 am
Satansfist
Quote:
Originally Posted by cb4265 View Post
...Nothing has changed, except the bikes mind?...
Bitch...
Aug 14th, 2017 4:17 am
cb4265 I just went out to my garage to check on the girls, and the charger is showing full lights as it did yesterday, so I stuck a voltmeter on it an it shows 13.8 volts, so I went and got the key.
The bloody thing started right up, WTF?

Yesterday, I got nothing but stuttering relays and no pump prime. Nothing has changed, except the bikes mind?

It's got me stuffed?

Craig
Aug 13th, 2017 9:21 pm
Spex
Quote:
Originally Posted by cb4265 View Post
For less than $200, you must have got the 290 CCA Model and not the 400CCA one?

Craig
Yeah sorry, just checked my eBay records and it was the LFP12B4. Same external dimensions as the LH but 290 vs 400 CCA. Next time around, I'll probably check the price on them but I'd be wondering if I really needed the extra 110 CCA. YMMV of course.
Aug 13th, 2017 9:14 pm
cb4265
Quote:
Originally Posted by Dave G View Post
SSB are in Lansvale Sydney. I'm talking to them at the moment about some batteries for a racing yacht that save about 50kg for a grand plus. I'll get a price for your battery if you want? I'm looking at starting a 1.5 litre diesel plus doing a bit of deep cycle at 700-1000 CCA. Maybe I can get a discount stacking them all together.

I started my poor neglected 900SS yesterday that has sat around for months and it kicked in straight away. 4 year old Shorai I liberated from the US that had been left around unused for a few years. They aren't terrible but I have have seen a few go bad. The guys who import them wanted to help me out with a deal on a new one but I was in and out of the country at the time and I never got it together
Thanks Dave, just make sure it's the LH12B4 400CCA. When are you in Muswellbrook again?

Craig
Aug 13th, 2017 4:35 pm
Dave G SSB are in Lansvale Sydney. I'm talking to them at the moment about some batteries for a racing yacht that save about 50kg for a grand plus. I'll get a price for your battery if you want? I'm looking at starting a 1.5 litre diesel plus doing a bit of deep cycle at 700-1000 CCA. Maybe I can get a discount stacking them all together.

I started my poor neglected 900SS yesterday that has sat around for months and it kicked in straight away. 4 year old Shorai I liberated from the US that had been left around unused for a few years. They aren't terrible but I have have seen a few go bad. The guys who import them wanted to help me out with a deal on a new one but I was in and out of the country at the time and I never got it together
Aug 13th, 2017 4:02 pm
cb4265
Quote:
Originally Posted by Spex View Post
That's the one I put in my Hyper when my Shorai started to crap itself. I got it from the RPM Moto ebay store, I think they had a special going so I got it for less than $200. Couple of years on, still starts like a champ. I've thought about getting a lithium-compatible charger but I haven't needed it yet.

It ships with a few little bits of adhesive-backed foam but nowhere near enough to pack it into the stock compartment. I had enough lying around to pack mine in so I used the bits that came with it to lift up the terminal nut to make it easier to do up the terminal screw.
For less than $200, you must have got the 290 CCA Model and not the 400CCA one?

Craig
Aug 13th, 2017 7:05 am
Able Duc
Quote:
Originally Posted by Spex View Post
lift up the terminal nut to make it easier to do up the terminal screw.
Yeah the terminal nuts, always shit me. If you have a couple of wires extra on your leads your always fuked. Yes putting something under the nuts is always the go that's good advice.
Aug 13th, 2017 6:39 am
Spex
Quote:
Originally Posted by cb4265 View Post
I have my heart set on a SSB LH12B4 LITHIUM BATTERY, but looking for a good price? Prices seem to vary quite a bit.
That's the one I put in my Hyper when my Shorai started to crap itself. I got it from the RPM Moto ebay store, I think they had a special going so I got it for less than $200. Couple of years on, still starts like a champ. I've thought about getting a lithium-compatible charger but I haven't needed it yet.

It ships with a few little bits of adhesive-backed foam but nowhere near enough to pack it into the stock compartment. I had enough lying around to pack mine in so I used the bits that came with it to lift up the terminal nut to make it easier to do up the terminal screw.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome