97 900 SS brake light prob - Ducati.ms - The Ultimate Ducati Forum
  • 1 Post By duc96cr
  • 1 Post By ducvet
  • 1 Post By Whealy
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Apr 11th, 2019, 9:10 pm Thread Starter
Junior Member
 
Join Date: Apr 2019
Location: Jindabyne, NSW, Australia
Posts: 6
97 900 SS brake light prob

G'day,

New to membership, but have read forum advice for years as I have owned a 97 900SS from new. Spent way too much on it, but love it and my boy will inherit it. Anyway, have a prob with the front brake operated brake light....not working. Rear brake is activating the tail light. Have shorted the wires at the front switch, still no go. Had a rough check of wiring integrity without luck also. Not much good with multi-meter stuff. Any ideas??

Cheers

Bill
Whealy is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Apr 11th, 2019, 11:47 pm
Administrator
 
scott's Avatar
 
Join Date: Dec 2003
Location: Sacramento, CA, USA
Posts: 11,355
Garage
Images: 2
Hi Bill and welcome. Is there a small plunger that actuates your brake light? I have had to clean and lubricate that on several motorcycles in the past.

Scott
Sacramento CA

'03 Ducati ST4S with ABS - '12 KTM 500EXC - '19 BMW R1250GSA
(Jessica Focker's) '15 BMW S1000RR - '17 KTM 350EXC-F - '09 Yamaha XT250


Some of the most asinine things people do are typically preceded by the two words "Watch this."
scott is offline  
post #3 of 8 (permalink) Old Apr 12th, 2019, 1:53 am Thread Starter
Junior Member
 
Join Date: Apr 2019
Location: Jindabyne, NSW, Australia
Posts: 6
Hi and thanks Scott,

No plunger that I'm aware of , there's a tiny switch at the end of the front brake lever, but I bypassed that and still no go.

One of those annoying probs that Dukes are renowned for...

Cheers

Bill
Whealy is offline  
 
post #4 of 8 (permalink) Old Apr 12th, 2019, 7:31 am
Prolific Poster Award
 
Join Date: Jul 2010
Location: Grass Lake, Mi, USA
Posts: 5,115
Images: 4
From time to time I go over the bike and unplug every electrical connector and rub the contacts with wd40 or such, checking for corrosion, and push the wires from each side back into the connectors. The factory sometimes puts zip ties too close to connectors , pulling on the wires enough to cause poor contact. If it looks dodgy in any way I fix it or replace it.
Whealy likes this.

'96 Ducati SS900CR, '07 S4RS, '06 Busa, '77 Bonny,
'00 Superglide, '85 Sportster, '78 SR500
duc96cr is offline  
post #5 of 8 (permalink) Old Apr 12th, 2019, 7:58 am
Senior Member
 
ducvet's Avatar
 
Join Date: Dec 2007
Location: lakes region, NH, usa
Posts: 3,118
Garage
Images: 1
If you are saying you shorted the two connectors at the switch (harness side) and did not have it work I would guess you may have the switch wires right at the master. Fiollow those wiress down to the steering head area (right side) and you should see them connect to the harness with 2 bullet connectors. With key on and wires disconnected you should be able to turn the brake light on by shorting these 2 harness side connectors. If not you may have a broken wire as it is the same circuit front and rear and you said the rear is working.

Harness issues are very rare on these bikes so odds are it is in the front brake switch or sub harness for the front brake switch. Also make sure no one changed the brake lever and lost the little black actuating puck that is only held in place by being trapped between the lever and switch. Do you have the switch with 2 wires built into it and about a foot of wire? Or the early switch that just has 2 male connectors right on the switch? Switches do fail and can be out of adjustment so before buying new figure out if it...

1. is the switch.
2. the switch just needs to be adjusted
3. someone lost the puck
Whealy likes this.
ducvet is offline  
post #6 of 8 (permalink) Old Apr 12th, 2019, 9:27 pm Thread Starter
Junior Member
 
Join Date: Apr 2019
Location: Jindabyne, NSW, Australia
Posts: 6
Thanks ....I have the switch with 2 x wires into it. ( gray / black ) I shorted these two wires together, with no result, so I guessed this eliminates the switch as the culprit?

I'll try your other recommendations.

Thanks again

B.
Whealy is offline  
post #7 of 8 (permalink) Old Apr 13th, 2019, 8:10 am
Senior Member
 
ducvet's Avatar
 
Join Date: Dec 2007
Location: lakes region, NH, usa
Posts: 3,118
Garage
Images: 1
Okay so just to verify you are shorting the harness side, a pair of needle nose pliers work well for this.
ducvet is offline  
post #8 of 8 (permalink) Old Apr 14th, 2019, 11:42 pm Thread Starter
Junior Member
 
Join Date: Apr 2019
Location: Jindabyne, NSW, Australia
Posts: 6
Thanks for all your help guys. Eventually found the prob, after taking headlight out and checking the first " bullet" connectors from the micro-switch ( as recommended by Ducvet ...thx ) , shorting them and eventually working out they were connected wrong by some idiot ( not mentioning names ! ) after a previous bit of maintenance.
All good now, thanks again for the helpful advuce.

Cheers

Bill
ducvet likes this.
Whealy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ducati.ms - The Ultimate Ducati Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
97 900 SS brake light prob Whealy Welcome and Introduction 5 Apr 12th, 2019 10:53 am
Brake lever not signaling rear brake light. Found rectifier dangling :( mike_delphin Sport Classic 15 Oct 28th, 2018 4:41 pm
Extra brake light Q Monster4Lee Monster 2 May 22nd, 2018 6:51 pm
2001 Monster 900 front brake light not working sicae Monster 4 Jul 11th, 2017 9:57 pm
Brake light won't stay on Sahand Akbari Tech Forum 4 Mar 14th, 2016 8:01 pm

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome