Input on a running issue - Ducati.ms - The Ultimate Ducati Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Aug 16th, 2019, 11:39 pm Thread Starter
Senior Member
 
kaos's Avatar
 
Join Date: Nov 2004
Location: nanaimo, british columbia, canada
Posts: 2,439
Input on a running issue

Any opinions on my 2004 999s engine issue . Everything runs perfect but for the last season when cruising at say 5-6 thousand rpm and it seems to hunt or very slightly surge if just slightly on the throttle . If you coast or accelerate everything runs well . Starts well , idles well, new battery , changed fuel filter and valves are in speck . Thought tps sensor but it checks with a multimeter . Fresh fuel and have run injector cleaner though it so Iím pretty well at a loss of what to check now

giallo 949- impractical,irrational,irresistible ,2017 Vertigo combat,2017 beta 300rr race ,2016 Husky 701 sm, all in all ,my version of garage nirvana
kaos is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ducati.ms - The Ultimate Ducati Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome