Check Engine Light 2006 ST3S - Ducati.ms - The Ultimate Ducati Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jul 25th, 2019, 12:13 pm Thread Starter
Senior Member
 
Zoomie's Avatar
 
Join Date: Oct 2013
Location: Mountain Home, Idaho, USA
Posts: 494
Oil Pressure Light 2006 ST3S

I used rubber plugs on the TBS synch nipples and one expired. I thought the Check Engine Light came on. Bad news, it was the oil pressure light. I drove home (< 5 miles) and had no expensive noises. . I replaced the synch nipples with proper metal plugs and gaskets. I started the engine and there was no Oil Pressure Light. The next day, I took the bike for a test ride and within three blocks, the Oil Pressure Light returned. The bike was running well.
Am I right in thinking and hoping this is an oil pressure and sensor issue? If so, how do I test it?

Zoomie: ST3S Lucrezia, BMW R1200RS
Gone: Guzzi Breva 1100,Bultaco Metralla & UJMCs

Last edited by Zoomie; Jul 25th, 2019 at 5:07 pm. Reason: Discovered error in thought process
Zoomie is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ducati.ms - The Ultimate Ducati Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome