Ducati.ms - The Ultimate Ducati Forum

Ducati.ms - The Ultimate Ducati Forum (https://www.ducati.ms/forums/)
-   Welcome and Introduction (https://www.ducati.ms/forums/165-welcome-introduction/)
-   -   97 900 SS brake light prob (https://www.ducati.ms/forums/165-welcome-introduction/721255-97-900-ss-brake-light-prob.html)

Whealy Apr 11th, 2019 9:10 pm

97 900 SS brake light prob
 
G'day,

New to membership, but have read forum advice for years as I have owned a 97 900SS from new. Spent way too much on it, but love it and my boy will inherit it. Anyway, have a prob with the front brake operated brake light....not working. Rear brake is activating the tail light. Have shorted the wires at the front switch, still no go. Had a rough check of wiring integrity without luck also. Not much good with multi-meter stuff. Any ideas??

Cheers

Bill

scott Apr 11th, 2019 11:47 pm

Hi Bill and welcome. Is there a small plunger that actuates your brake light? I have had to clean and lubricate that on several motorcycles in the past.

Whealy Apr 12th, 2019 1:53 am

Hi and thanks Scott,

No plunger that I'm aware of , there's a tiny switch at the end of the front brake lever, but I bypassed that and still no go.

One of those annoying probs that Dukes are renowned for...

Cheers

Bill

duc96cr Apr 12th, 2019 7:31 am

From time to time I go over the bike and unplug every electrical connector and rub the contacts with wd40 or such, checking for corrosion, and push the wires from each side back into the connectors. The factory sometimes puts zip ties too close to connectors , pulling on the wires enough to cause poor contact. If it looks dodgy in any way I fix it or replace it.

ducvet Apr 12th, 2019 7:58 am

If you are saying you shorted the two connectors at the switch (harness side) and did not have it work I would guess you may have the switch wires right at the master. Fiollow those wiress down to the steering head area (right side) and you should see them connect to the harness with 2 bullet connectors. With key on and wires disconnected you should be able to turn the brake light on by shorting these 2 harness side connectors. If not you may have a broken wire as it is the same circuit front and rear and you said the rear is working.

Harness issues are very rare on these bikes so odds are it is in the front brake switch or sub harness for the front brake switch. Also make sure no one changed the brake lever and lost the little black actuating puck that is only held in place by being trapped between the lever and switch. Do you have the switch with 2 wires built into it and about a foot of wire? Or the early switch that just has 2 male connectors right on the switch? Switches do fail and can be out of adjustment so before buying new figure out if it...

1. is the switch.
2. the switch just needs to be adjusted
3. someone lost the puck

scott Apr 12th, 2019 10:53 am

I copied this thread over to the Supersport forum for more eyes and help:
https://www.ducati.ms/forums/57-supe...ight-prob.html


All times are GMT -5. The time now is 2:51 pm.

Ducati.ms Web Community is powered by: vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome