ducatidiag Wow! - Page 15 - Ducati.ms - The Ultimate Ducati Forum
http://www.ducati.ms/forums
» Sponsors
» Insurance
Go Back   Ducati.ms - The Ultimate Ducati Forum > Ducati Motorcycle Forums > Sport Touring

Reply
 
LinkBack Thread Tools Display Modes
Old Apr 23rd, 2012, 10:22 am   #141 (permalink)
Mr Leakered
 
tonered's Avatar
 
Join Date: Jul 2008
Location: Lynnwood, WA, USA
Posts: 7,435
Images: 21
Quote:
Originally Posted by jentech View Post
Ok, I am either really dumb or perhaps have a bad cable. I picked the cables up yesterday, and have connected the FIAT cable to power from the battery tender connector and am not getting any power on any of the pins on the VAG end. I connected it to the OBD cable and the light is not on. Tried reversing the alligator clips on the the tender lead and still nothing. Plugging in the VAG to the computer on it's own I get a red led. Fire up the program and I get a green bar on COM 5 connection as well. Tried the cable test with both cables together but don't get any power on any of the three pins on the ECU plug. Bad cable?? Complete idiot? Any other ideas? thanks.

ok, did some more testing, and am getting power on the VAG end of the FIAT connector, but it's on PIN 9, not 16, or am I looking at it in reverse?
Here's the pin outs for the Fiat/Alfa cable:

EDIT: nevermind. Doing some searches shows the pinout numbering in the link to be reversed. Sorry.

It seems that jduke also received an iffy cable. WTH?

Have a good one.
__________________
tony b
2001 ST4 (Hello, my name is Thumper )
2013 Ural GearUp (Taildragger)

Last edited by tonered; Apr 23rd, 2012 at 1:17 pm.
tonered is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old Apr 23rd, 2012, 10:26 am   #142 (permalink)
Mr Leakered
 
tonered's Avatar
 
Join Date: Jul 2008
Location: Lynnwood, WA, USA
Posts: 7,435
Images: 21
Quote:
Originally Posted by mrturbozxj View Post
Just want to throw in that I managed to get my 98 ST communicating with a cable I got from Bob92 here on the forum. Polarity was right on the cable, so no extra crispy ECU. Just used a boring old laptop with XP as my PC.

It did take a second to realize you needed to click connect, then turn on the kill switch, after doing that, live data galore.

The "old" ECU version is kind of limited in what it can do, but you do get live readouts from your sensors, you can see the ignition and injector timing. A perfect way to check the temp sensors as you can get readings from one going to the ECU and compare against the gauge cluster.

For $22 in cables and a few minutes, it is pretty impressive that you can get live ECU data from these things.

edit: @jentech

Your cable has the battery + on the right pins, that is #16. I'd make sure that ground is working right as well.
I don't think you'll see any voltage coming off the fiat connector unless you go to that ground and are trying to communicate w/ the bike.
Nice work. Seeing the sensor output is very cool.

Did your ECU happen to report the full ECU data?

Have a good one.
__________________
tony b
2001 ST4 (Hello, my name is Thumper )
2013 Ural GearUp (Taildragger)
tonered is online now   Reply With Quote
Old Apr 23rd, 2012, 10:31 am   #143 (permalink)
Mr Leakered
 
tonered's Avatar
 
Join Date: Jul 2008
Location: Lynnwood, WA, USA
Posts: 7,435
Images: 21
Quote:
Originally Posted by DropLock View Post
Here essentially are those posts:

P1 I haven't gone further than this, but there are recommend cables to buy cheap from ebay. After that, you get a screen dump out of your ECU, post it to the site and the developer will send a licence file for free.

P4 The cables for the 1.5m and 1.6m seem to be less expensive on Amazon:

Amazon.com: OBD OBD2 16 Pin Connector Diagnostic Adapter for FIAT 3 Pin: Car Electronics
Amazon.com: OBD OBD2 16 Pin Connector Diagnostic Adapter for FIAT 3 Pin: Car Electronics

Amazon.com: OBD2 OBD II Diagnostic USB Cable For KKL409.1 VAG-COM 409: Camera & Photo
Amazon.com: OBD2 OBD II Diagnostic USB Cable For KKL409.1 VAG-COM 409: Camera & Photo

P39 (on page 4) The first pic is a just-in-case cable test of a premanufactured SAE extension cable. It came with the Slime Motosports Tire Pump.

The second pic is the Fiat/Alfa cable connected to the SAE extension cable and the 1.6m ECU interface. It hangs out with a cap near those rear fuses when not in use.

The third pic is the Fiat/Alfa cable to OBD cable connection. It is hard to see, but the blue LED is glowing signifying a solid connection.

The fourth pic is the set up with my laptop.

The fifth pic is just the gratuitous nastiness of my ST and my [remaining] kingdom. =P

Link to that post for pics: ducatidiag Wow!

P40 The third attachment is the pre-key on connection. The green bar under the connect/disconnect switch signifies a good connection. Same as the blue OBD LED, I believe. And that you are one the proper COM port.

The first attachment is the key on / motor off. Note the MAP data! 8)

The second attachment is the motor running.

P42 (page 5) Hahahahahahahahahahaha! Check this out.

If you tap the "Test" button in the menu bar after ducatidiag has a connection, you get to run some tests! This wasn't working for me on Monday because I wasn't getting data. So, I left it alone the past couple days. Well, jpl250rs suggested that I hit it.

Attached is the result. With the key on / motor off I got the following tests.

test 1 is the fuel pump. You see the repetition because it was running for a while and I thought tapping the fuel pump button again would turn it off.

The others are just me hitting buttons. They went much quicker. Probably 1/3 the time. Wondrous. I believe the 5.9m and 5am versions have even cooler tests to run.

P46 Good point. I think you can only get here once you are registered. Here's the link for the future as I always have to dig for it myself:HitCounter

Thought I'd put this together in one post. In response to the original question of whether these posts make it clear...I don't know, I still have to sort through it again.



My cables are at the P.O. so I'll go and pick them up tomorrow. Before I can even begin to answer the above question it seems I first need to sort out whether the cables I've got have the right polarity.

Can anyone post something that concicely explains how to check which pin etc to continuity?. I'm starting out confused here.
DropLock,

That is pretty much the summary. Thanks.

Just click the link in Post 93 or 141. That link takes you to the ducatidiag forum where some polarity discussion was going on. The first post in that thread has the pin out diagram for the Fiat/Alfa cable. You can test your cable against that. Note, the pin numbering is reversed, in the link. So, the locations are wrong, but the outputs seem to be correct for those NUMBERed pins.

Have a good one.
__________________
tony b
2001 ST4 (Hello, my name is Thumper )
2013 Ural GearUp (Taildragger)

Last edited by tonered; Apr 23rd, 2012 at 1:21 pm.
tonered is online now   Reply With Quote
Old Apr 23rd, 2012, 10:57 am   #144 (permalink)
Mr Leakered
 
tonered's Avatar
 
Join Date: Jul 2008
Location: Lynnwood, WA, USA
Posts: 7,435
Images: 21
Just a little sleuthing. jentech and jduke, where did you source your cables from? Amazon, eBay, or someplace else. I'm just wondering if we can pinpoint a bad source or if it is just a weird coincidence.

My Amazon order history shows that the Fiat/Alfa cable was sold by Soliport and the OBD cable was sold by Amazan warehouse (singapore). No spelling error there. LoL! They did come shrink wrapped together in a single package.

Have a good one.
__________________
tony b
2001 ST4 (Hello, my name is Thumper )
2013 Ural GearUp (Taildragger)
tonered is online now   Reply With Quote
Old Apr 23rd, 2012, 1:01 pm   #145 (permalink)
Member
 
jentech's Avatar
 
Join Date: Nov 2011
Location: Vancouver, BC, Canada
Posts: 41
Images: 2
Quote:
Originally Posted by tonered View Post
Just a little sleuthing. jentech and jduke, where did you source your cables from? Amazon, eBay, or someplace else. I'm just wondering if we can pinpoint a bad source or if it is just a weird coincidence.

My Amazon order history shows that the Fiat/Alfa cable was sold by Soliport and the OBD cable was sold by Amazan warehouse (singapore). No spelling error there. LoL! They did come shrink wrapped together in a single package.

Have a good one.
Ordered mine from Amazon. Fiat/Alfa cable came from Soliport (which I seem to having problems with) and the OBD cable came from Loftek Technological (which might explain why it has a red instead of blue led). Also, they came in separate boxes.


Sent from my Motorcycle iPad app
__________________
Scott '06 ST3s DP ECU, Termi's, Helibars, Corbin seat - 'Monica'
jentech is offline   Reply With Quote
Old Apr 23rd, 2012, 1:11 pm   #146 (permalink)
Senior Member
 
Join Date: Feb 2012
Location: Savannah, Georgia [GA], United States
Posts: 991
EBAY
I ordered both my cables from China and they shipped directly from China.
Fiat cable was $6.35 delivered, seller was GREENBIDSHOP, 99.9% rating
VAG cable was $9.49 delivered, seller was EPATHCHINA_GAME, 99.1% rating
I tested the VAG cable and could successfully test power getting to the cable, but none of the pins showed power a that end.
I took the cable apart and it looks like the failure is on the circuit board.
I notified the seller and they are sending another cable, which will take another 2 weeks.
Tony let me borrow his set of cables and I ordered a set from Bob92.
Once the cables get here I should be able to test them pretty quick and hook up everything to my bike and see what happens.
No smoke, I do NOT WANT SMOKE
__________________
Jerry Duke

2004 ST4s ABS
2001 YELLOW Monster M900Sie
1993 Honda CBR600F2 - trackday bike
jduke is online now   Reply With Quote
Old Apr 23rd, 2012, 1:26 pm   #147 (permalink)
Mr Leakered
 
tonered's Avatar
 
Join Date: Jul 2008
Location: Lynnwood, WA, USA
Posts: 7,435
Images: 21
Quote:
Originally Posted by jentech View Post
Ok, that's a bit of a relief, I took the fairing off and checked the connections at the battery as well, but in the ducatidiag Cable Test, I don't get any voltage on the FIAT pins and if I connect everything up and turn the key, I don't get any info coming up. Will take another look again tomorrow after work. Thanks.
Sorry about the confusion with that pinout link. Here's a correct one:
Ross-Tech: VAG-COM: Afterrmarket Radio Problem

One other question, did you download the latest drivers for your OBD cable?

Have a good one.
__________________
tony b
2001 ST4 (Hello, my name is Thumper )
2013 Ural GearUp (Taildragger)
tonered is online now   Reply With Quote
Old Apr 23rd, 2012, 1:28 pm   #148 (permalink)
Senior Member
 
Join Date: Apr 2008
Location: Denver Metro, CO, USA
Posts: 241
Quote:
Originally Posted by tonered View Post
Nice work. Seeing the sensor output is very cool.

Did your ECU happen to report the full ECU data?

Have a good one.
Not sure what else the old ECUs can report other than live sensor info (unless i'm missing something) Is there a way to pull the map to at least look at it?
__________________
'98 ST2
'84 Kawasaki Gpz Turbo
mrturbozxj is offline   Reply With Quote
Old Apr 23rd, 2012, 1:29 pm   #149 (permalink)
Mr Leakered
 
tonered's Avatar
 
Join Date: Jul 2008
Location: Lynnwood, WA, USA
Posts: 7,435
Images: 21
Quote:
Originally Posted by jduke View Post
EBAY
I ordered both my cables from China and they shipped directly from China.
Fiat cable was $6.35 delivered, seller was GREENBIDSHOP, 99.9% rating
VAG cable was $9.49 delivered, seller was EPATHCHINA_GAME, 99.1% rating
I tested the VAG cable and could successfully test power getting to the cable, but none of the pins showed power a that end.
I took the cable apart and it looks like the failure is on the circuit board.
I notified the seller and they are sending another cable, which will take another 2 weeks.
Tony let me borrow his set of cables and I ordered a set from Bob92.
Once the cables get here I should be able to test them pretty quick and hook up everything to my bike and see what happens.
No smoke, I do NOT WANT SMOKE
You are definitely taking the cautious approach. It was a longer/harder road than should have been necessary, but with your future usage, the wait should be worth it.

Have a good one.
__________________
tony b
2001 ST4 (Hello, my name is Thumper )
2013 Ural GearUp (Taildragger)
tonered is online now   Reply With Quote
Old Apr 23rd, 2012, 1:32 pm   #150 (permalink)
Member
 
jentech's Avatar
 
Join Date: Nov 2011
Location: Vancouver, BC, Canada
Posts: 41
Images: 2
Quote:
Originally Posted by tonered View Post
Sorry about the confusion with that pinout link. Here's a correct one:
Ross-Tech: VAG-COM: Afterrmarket Radio Problem

One other question, did you download the latest drivers for your OBD cable?

Have a good one.
Ok, according to that link I am getting 12V on pin 16 which means the Fiat cable should be ok. I originally used the driver that came with the cable, but uninstalled it and downloaded the one from this forum. It shows up on COM5. I'll try reconnecting everything tonight and try again, but perhaps it is the OBD cable giving problems. Also, how long does it take to connect once you turn the key?


Sent from my Motorcycle iPad app
__________________
Scott '06 ST3s DP ECU, Termi's, Helibars, Corbin seat - 'Monica'
jentech is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ducatidiag, a must have for every HM owner! Drinky HyperMotard 108 Aug 13th, 2014 6:51 am
Ducatidiag Jester4always Sport Classic 11 Apr 13th, 2012 8:24 pm

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:06 am.



Ducati.ms Web Community is powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum