CEL Light Came On - Ducati.ms - The Ultimate Ducati Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old Sep 19th, 2010, 3:49 pm Thread Starter
Senior Member
 
Join Date: Jul 2010
Location: Atlanta, GA, USA
Posts: 147
CEL Light Came On

I just purchased a used factory stock Streetfighter and about fifty miles into my ride yesterday, the CEL light came on. Interestingly, the first forty nine miles or so, I was going 80-95 MPH and all was fine. Then I slowed down to 55-60 MPH because one of mirrors had worked itself loose. I suppose I was lugging it around a little too much but as soon as I turned the bike off, re-started it and resumed the 80-95 MPH run all was fine. Any ideas?

By the way, this thing is awesome!
955ST4 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old Sep 19th, 2010, 4:00 pm
Senior Member
 
Maximmagnum's Avatar
 
Join Date: Jan 2010
Location: Arvada, CO, USA
Posts: 1,563
The exhaust valve got stuck--just turn off the bike and restart it, it will be fine...very common problem.

James

-White F1098 Streetfighter
Maximmagnum is offline  
post #3 of 10 (permalink) Old Sep 19th, 2010, 4:10 pm
cts
Senior Member
 
cts's Avatar
 
Join Date: Aug 2009
Location: Athens, Agios Dimitrios, Greece
Posts: 1,805
also check if it has done the ECU map upgrade...i got cel before the upgrade when on low speed/low revs/little throttle...

'04 YAMAHA 660XTX (sold)
'07 KAWASAKI Z750 (sold)
'10 DUCATI Streetfighter S
'05 DUCATI S2R 800
'01 KYMCO BW 125cc
cts is offline  
post #4 of 10 (permalink) Old Sep 19th, 2010, 4:57 pm Thread Starter
Senior Member
 
Join Date: Jul 2010
Location: Atlanta, GA, USA
Posts: 147
Thanks.
955ST4 is offline  
post #5 of 10 (permalink) Old Sep 19th, 2010, 5:43 pm
Temporary greeter
 
Wonway's Avatar
 
Join Date: Jan 2010
Location: Chicago, IL., USA
Posts: 22,046
Garage
Images: 1
There should be a code displayed on the screen at some time when the CEL is on. If it is EXVL or similar, it is what they say above. Otherwise take it in and have them check to be sure.
Wonway is offline  
post #6 of 10 (permalink) Old Sep 19th, 2010, 5:52 pm Thread Starter
Senior Member
 
Join Date: Jul 2010
Location: Atlanta, GA, USA
Posts: 147
Thanks again.
955ST4 is offline  
post #7 of 10 (permalink) Old Sep 19th, 2010, 7:35 pm
Senior Member
 
LessPeople_MoreRobots's Avatar
 
Join Date: May 2009
Location: Spring, TX, USA
Posts: 593
Quote:
Originally Posted by Maximmagnum View Post
The exhaust valve got stuck--just turn off the bike and restart it, it will be fine...very common problem.
I can confirm. It does this periodically, usually just after you've gone about 40-50mi or so.

Current: 2014 Monster 1200 S
Previous:Multistrada 1200 ABS, 1098, Streetfighter 1098, 1098, Monster 900ie
LessPeople_MoreRobots is offline  
post #8 of 10 (permalink) Old Sep 20th, 2010, 12:38 am
Senior Member
 
fighterpilot's Avatar
 
Join Date: Jun 2009
Location: Honolulu, Hawaii, USA
Posts: 2,083
Quote:
Originally Posted by LessPeople_MoreRobots View Post
I can confirm. It does this periodically, usually just after you've gone about 40-50mi or so.
Time for a warranty replacement of the exhaust valve servo motor, had mine replaced a couple of weeks ago...

Black 2014 Speed Triple R
White 2010 Streetfighter (sold)

-you only live once, and I feel like I'm running out of time...
fighterpilot is online now  
post #9 of 10 (permalink) Old Sep 20th, 2010, 2:54 am
cts
Senior Member
 
cts's Avatar
 
Join Date: Aug 2009
Location: Athens, Agios Dimitrios, Greece
Posts: 1,805
i claimed a warranty. still waiting for the part to come. BUT, i put on the termi slip ons and...no more cel lights for me....
?%!@$!%???

'04 YAMAHA 660XTX (sold)
'07 KAWASAKI Z750 (sold)
'10 DUCATI Streetfighter S
'05 DUCATI S2R 800
'01 KYMCO BW 125cc
cts is offline  
post #10 of 10 (permalink) Old Sep 20th, 2010, 7:17 am Thread Starter
Senior Member
 
Join Date: Jul 2010
Location: Atlanta, GA, USA
Posts: 147
Just curious, does the Full Termi exhaust have a flapper valve? I'm thinking about adding that right now if it makes a noticeable difference in performance.
955ST4 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ducati.ms - The Ultimate Ducati Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Light on after head light bucket removed rapter Superbikes 4 Sep 28th, 2009 11:26 am
Park Light as daytime running light? Fritzi Sport Classic 9 Jun 27th, 2008 6:54 pm
Back light not working (break light is) Bugatti Superbikes 4 Oct 11th, 2007 12:21 am
front sprocket/light on dash/rev light for 998 donno Superbikes 7 Jul 12th, 2006 3:13 am

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome